100% 주문제작형 고퀄리티 워드프레스홈페이지 제작 전문_워드프레서

워드프레스는 보안에 취약할까?
워드프레스는 보안에 취약할까?

워드프레스는 보안에 취약할까?

워드프레스는 정말 보안에 취약할까?

워드프레스로 홈페이지 제작 서비스를 제공하다 보니 워드프레스가 보안에 취약하지 않냐는 문의를 간혹 받게 됩니다. 워드프레스가 보안에 취약하다고 지적하는 뉴스도 간혹 보입니다. 

“워드프레스에 심각한 보안취약점…공격에 활용된 정황 포착. 데일리큐브. 2021. 02.08.”

“이메일 조작 취약점 발견된 워드프레스, 현재 해커들끼리의 싸움거리. 보안뉴스 2020. 09. 14.”

결론을 먼저 말하자면 워드프레스 자체는 안전합니다. 그렇다면 왜 워드프레스가 보안에 취약하다는 얘기가 나오는지 먼저 알아보겠습니다. 

많이 사용하기 때문에 해커의 공격 대상이 된다!

현재 전세계의 30% 정도가 워드프레스로 제작되었을 정도로 워드프레스의 인기가 높습니다. 마이크로소프트, BBC, 뉴욕타임즈, 벤츠 등 전세계적인 기업뿐만 아니라 백악관 홈페이지 또한 워드프레스로 제작되었습니다. 많이 사용하기 때문에 해커들의 공격 대상이 되며, 해킹을 당했다는 관련 기사가 나올 수 밖에 없습니다. 

다른 예를 들자면 많은 사용자들이 Windows를 사용하기 때문에 해커들의 공격 대상이 됩니다. 그래서 마이크로소프트에서는 수시로 업데이트를 제공하고 있습니다. 업데이트가 제공되는 데에도 불구하고 업데이트를 설치하지 않으면 보안에 취약해 질 수 밖에 없습니다. 결국 Windows 보안 문제라기 보다는 사용자들이 업데이트를 하지 않아 보안에 취약해진 상황이 됩니다. 

워드프레스는 매년 두 차례 정도 메이저 업데이트가 제공되고, 보안 취약점이 발견될 때마다 수시로 보안 업데이트를 제공합니다. 워드프레스 자체는 안전하지만 올바르게 사용하지 않을 때 보안에 취약해 질 수 밖에 없습니다. 

워드프레스를 안전하게 사용하기 위해 기본만 지키자!

다음과 같은 기본적인 사항만 준수해도 워드프레스는 안전하게 사용할 수 있습니다. 

1. 보안 플러그인 사용

워드프레스 보안 플러그인을 설치하면 스팸, 사이트 해킹 시도 등을 효과적으로 차단할 수 있습니다. 

2. 최신 버전으로 업데이트

워드프레스, 테마, 플러그인을 항상 최신 버전으로 업데이트하여 유지하는 것이 중요합니다. PHP 버전도 가급적 최신 버전을 사용해야 속도 및 보안에 유리합니다. 특히 PHP 5.x는 수명 완료일이 이미 완료되어 더 이상 보안 패치를 제공하지 않으므로 사용하지 않은 것이 안전합니다. 

3. 정기적인 백업

자체 백업 기능을 제공하는 웹호스팅을 사용하거나 백업 플러그인을 활용하여 홈페이지에 문제가 발생할 경우 쉽게 복원할 수 있도록 정기적으로 백업하는 것도 중요합니다.

4. 올바른 플러그인 선택

잘 못 만들어진 플러그인이나 오랫동안 업데이트가 안 된 플러그인의 경우 보안에 취약할 수 있으므로, 지속적인 업데이트를 제공하고 있는 플러그인을 선택하여 사용하는 것이 좋습니다.

5. 관리자 화면 보안 강화

관리자 아이디를 admin 또는 도메인 이름을 사용하지 말고, 비밀번호를 강력하게 설정하도록 합니다. 

워드프레스는 보안에 문제가 없지만 사용자의 잘못된 사용으로 인해 보안에 헛점이 생길 수 있습니다. 기본적인 사항을 준수하여 안전하게 워드프레스를 사용하시기 바랍니다.